Recommend my post:
Do these before you ask
The newest book and d2l package
My repo recording all my learning:


Maybe my question seems silly. I never used MXNET before and I prefer Tensorflow, but I can’t open some implementation in Tensorflow. In the explorer, it shows .ipynb file size is 0KB and in the jupyter notebook, shows error “Unreadable Notebook: D:\Python scripts\d2l-en\tensorflow\chapter_generative-adversarial-networks\dcgan.ipynb NotJSONError(“Notebook does not appear to be JSON: ‘’…”)”. Help me. Btw, mxnet implementation works okay.


You can check the chapter DCGAN, then you will find that there isn’t tensorflow code now.

You can join us to translate from mxnet to tensorflow.
I’m translating DCGAN from mxnet to pytorch, but still stuck.

Oh I see :slight_smile:
Unfortunately I am new to MXNET, I afraid I can’t.

Thanks for response.

I’m new to pytorch and mxnet too.
Then I have translated GAN from pytorch and mxnet.

If you follow the book step by step, I think it won’t be hard for you.

And I found Chapter 17. Representation Learning and Generative Learning Using Autoencoders and GANs:

Maybe it will help you if you are a member of Oreilly or ACM.

Hi, I am new to this. I have just installed miniconda on Widdows. How to perform the next step?

  1. Download the corresponding Miniconda sh file from the website and then execute the installation from the command line using sh <FILENAME> -b .
  2. Download the D2L notebook?

Open your cmd(win+r then cmd)
Do next

It seems that tensorflow does not have a build for python3.9, so when I type(I don’t know if comment pages support markdown rendering)

pip install tensorflow

It shows the result below.

The solution is to downgrade python3.9 to 3.8 in the virtual env. Or specify python version when creating d2l env.

conda create --name d2l python=3.8

After downgrading my python version to 3.85, everything works fine.

Hi @woshiZS, great catch! Thanks for reporting the potential issues!

Hello, has anyone else come across this issue with using the Jupyter notebook, I have a dead kernel

This issue has been resolved, I had to install Ipython while in the d2l environment

Minor correction on Section: Downloading the D2L Notebooks
Windows cmd is “del” and not “rm”

mkdir d2l-en && cd d2l-en
curl -o
unzip && rm

unzip && del

Hi, I have a question if I try to install tensorflow and then d2l, I get the following conflict

ERROR: pip’s dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
d2l 0.17.3 requires numpy==1.18.5, but you have numpy 1.22.2 which is incompatible.

If I try it the other way around I get the problem with tensorflow.

Use pip install tensorflow tensorflow-probability numpy==1.18.5

typo on this page: “we can the Jupyter notebook server by running”

Just a minor issue.
Following Installation I installed Miniconda, tensorflow and d2l (1.0.0a1.post0 !) for Windows 11.
The notebook works well so far except that labels, cites etc. don’t work. They just show up as ‘:label: xxx’, ‘:cite: xxx’, etc.
Is there a fix for this?