Hi @Shashwat, could specify the Ubuntu version you are using? Is it a local installation without GPU?


My first search from google:
It may helps you. Can you tell me where do you download there ipynb files?
And more details?

Do you install jupyter?
Maybe you don’t install jupyter book.

Read And then you can find these to install jupyter notebook

conda install notebook


pip install notebook

Any other problem? Look Do these before you ask!. Figure it out by yourself first.

I think we don’t tell them to install jupyter at all.
new commit:
Help me review!

I am using Ubuntu 18.04 with GTX 1050ti graphics card.

Thanks Steven,
I already tried the approaches suggested in But they were of no help. I even tried renaming them with a .html extension but it didn’t help either.

I downloaded the ipynb files from from the All notebooks section.

And yeah I am using Jupyter to run these files.

I still can’t find your real problem. Have you run other .ipynb that is not in this book files before?

But there is what you can try:

  1. update your jupyter
  2. read again:

    Have you run jupyter notebook first, then read files in your browser?
  3. install VScode to open it directly: Using Jupyter
  4. read
    I guess you choose ipynb files from local disk.

Once all packages are installed, you can open the Jupyter notebook by

jupyter notebook

At this point open http://localhost:8888 (which usually opens automatically) in the browser, then you can view and run the code in each section of the book.


You’re trying to run the pytorch code that we don’t have now…
Please look this for more details.

Hello May be it is very easy problem … I have struggled to solve it but I can’t

I installed torch & torch vision CPU only version as book guided

after installation, I activate virtual env & activate Jupyter notebook and run the code of notebook . I also install requests as your guidance

I met error message like this
OSError: [WinError 126] 지정된 모듈을 찾을 수 없습니다.
Error loading “C:~~\torch\lib\asmjit.dll” or one of its dependencies.

Plz give me a guide to fix it.


google first… And convert your language to English next time

@Shashwat Did you have a solution? I have the same problem like you.
In pytorch folder:

  • I can’t open index.ipynb
  • I can’t open /chapter_introduction/index.ipynb
  • But, I can open /chapter_optimization/adadelta.ipynb

Could someone help me, please?

Because there isn’t any code in index…

in my linux, mxnet is cuda-100, why?


from mxnet import npx plz
click mxnet tab to discuss mxnet next time

why I cannot import ? thanks reply.

**image **

Hi @HeartSea15, please post MXNet installation issue under MXNet tag. You may need to upgrade to MXNet 1.7.

I got the same error when I tried to run notebooks with .ipynb extension. Looking closely at the files listed, I noticed that several files were 0 B in size. Selecting files with valid size (i.e., which have some content in them) works as expected.

It’s not clear to me why the empty files exist in the first place. Perhaps they can be removed. Hope that helps.

Thank you, that helps.

So, I think they should add some content to the zero-byte files, in order to avoid these kind of annoyances.

Hey @TEX, does it still bother you? Try git pull origin to pull the latest code may help!

1 Like

Hi all! I am also using the pytorch version of the notebooks (downloaded today, 25.Oct.20) and get the error that the notebooks cannot be read. There seem to be two reasons for this, both are bugs in the way the d2l team builds the books. One source of errors is the fact that some notebooks haven’t added the pytorch code yet. Instead of adding a note saying something like ‘not implemented yet’ it just produces a notebook of the size 0. The other source of errors is that those markdown files (which are the source of the notebook files), which don’t have a tag ‘pytorch’ included, are not converted to pytorch notebooks. This includes all index files (and I think generally all files without code). If you have the time, you could fix the first error in the build system ( . The second error needs to be fixed in the markdown files for the book, they need to add a tab all directive there (so I gather from the discussion on the build system). What we can do to get the index files and other text files: copy these files from the mxnet branch. They have no code and work also with the pytorch branch.

Hi @fotis we are working to add the pytorch code blocks for the chapters which are still left. Once those are added the notebook versions of the same will be available.

Probably @mli can shed some light on whether we’ll add a “Not Implemented Yet” mark to the chapters left.

1 Like

the solution about “No module named ‘requests’”:

  1. open your anaconda botton “Enviroment” botton “d2l” (if you have finished Installation’s order ,you will find “d2l” ) “not installed” and search “requests”(and you will find it on the list)
  2. click “Appliy” botton
    6.reactivate the d2l environment.
1 Like