Installation

I got the same error when I tried to run notebooks with .ipynb extension. Looking closely at the files listed, I noticed that several files were 0 B in size. Selecting files with valid size (i.e., which have some content in them) works as expected.

It’s not clear to me why the empty files exist in the first place. Perhaps they can be removed. Hope that helps.

Thank you, that helps.

So, I think they should add some content to the zero-byte files, in order to avoid these kind of annoyances.

Hey @TEX, does it still bother you? Try git pull origin to pull the latest code may help!

1 Like

Hi all! I am also using the pytorch version of the notebooks (downloaded today, 25.Oct.20) and get the error that the notebooks cannot be read. There seem to be two reasons for this, both are bugs in the way the d2l team builds the books. One source of errors is the fact that some notebooks haven’t added the pytorch code yet. Instead of adding a note saying something like ‘not implemented yet’ it just produces a notebook of the size 0. The other source of errors is that those markdown files (which are the source of the notebook files), which don’t have a tag ‘pytorch’ included, are not converted to pytorch notebooks. This includes all index files (and I think generally all files without code). If you have the time, you could fix the first error in the build system (https://github.com/d2l-ai/d2l-book) . The second error needs to be fixed in the markdown files for the book, they need to add a tab all directive there (so I gather from the discussion on the build system). What we can do to get the index files and other text files: copy these files from the mxnet branch. They have no code and work also with the pytorch branch.

Hi @fotis we are working to add the pytorch code blocks for the chapters which are still left. Once those are added the notebook versions of the same will be available.

Probably @mli can shed some light on whether we’ll add a “Not Implemented Yet” mark to the chapters left.

1 Like

the solution about “No module named ‘requests’”:

  1. open your anaconda
    2.click botton “Enviroment”
    3.click botton “d2l” (if you have finished Installation’s order ,you will find “d2l” )
    4.select “not installed” and search “requests”(and you will find it on the list)
  2. click “Appliy” botton
    6.reactivate the d2l environment.
1 Like