安装

pip install torch==1.8.1+cu111 torchvision==0.9.1+cu111 torchaudio==0.8.1 -f https://download.pytorch.org/whl/torch_stable.html可以安装好和本书对应的gpu版本

ModuleNotFoundError: No module named ‘d21’
image
问一下这是什么原因呢,我安装了d21包但是导入的时候显示没有

请问一下各位,在conda d2l环境下用pip install 到开始下载时窗口就会闪退是怎么回事呢

你好,我想在pycharm中使用d2l包(pytorch版)进行开发,但是由于目前直接pip下来的是适用于jupyter的,有一些魔术命令无法运行,有什么解决办法吗这应该是一个比较通用的问题,希望能得到解答

已解决
直接pip install matplotlib_inline 就可以了,但是还要在源程序(不是d2l的包里面写)d2l.plt.show()

请问一下大家,用pip install 命令安装库,程序运行到下图downloading时窗口就会闪退。原来一直可以用的,是因为我误删了某个文件嘛? 重装conda还是没用。。

我也是,同款电脑同款报错,老哥解决了吗?我搞了好久都没好

m1问题解决了
1、先从下载d2l包到本地文件
2、利用sys查看python包所在目录
import sys
print(sys.pat)
第三方包安装位置一般是site-package结尾
3、d2l目录导入
4、python中import d2l会提示缺少各种依赖的包,pip安装就好
注意:当出现ImportError: cannot import name ‘PILLOW_VERSION’ from ‘PIL’ (/Users/dcj/miniforge3/envs/d2l-zh/lib/python3.8/site-packages/PIL/init.py)
需要修改上面提示出现错误的py脚本中PILLOW_VERSION,将其改成__version__
因为PIL7.0版本以后用__version__替换PILLOW_VERSION
5、再import d2l一般就不会报错

问题解决了,我在下面评论回复了,离线下载安装成功的,命令安装还不成功就很奇怪 :face_with_raised_eyebrow:

m1问题解决了
1、先从下载d2l包到本地文件
2、利用sys查看python包所在目录
import sys
print(sys.pat)
第三方包安装位置一般是site-package结尾
3、d2l目录导入
4、python中import d2l会提示缺少各种依赖的包,pip安装就好
注意:当出现ImportError: cannot import name ‘PILLOW_VERSION’ from ‘PIL’ (/Users/dcj/miniforge3/envs/d2l-zh/lib/python3.8/site-packages/PIL/ init .py)
需要修改上面提示出现错误的py脚本中PILLOW_VERSION,将其改成__version__
因为PIL7.0版本以后用__version__替换PILLOW_VERSION
5、再import d2l一般就不会报错

我的问题我后来看了一下,是因为d2l==0.17.3 这个包需要 numpy==1.18.5, 但是m1 mac不支持直接pip或者conda安装这个版本的numpy.
我找了一个相应的轮子给numpy==1.18.5装上就好了.

具体的轮子在这里包着:

我也写了个博客记录了一下详细过程:

我的问题我后来看了一下,是因为d2l==0.17.3 这个包需要 numpy==1.18.5, 但是m1 mac不支持直接pip或者conda安装这个版本的numpy.
我找了一个相应的轮子给numpy==1.18.5装上就好了.

具体的轮子在这里包着:

我也记录了一下详细的安装过程

你好,我也遇到这个问题。。。你解决了吗?

我有两个问题想请教一下:1.nvidia官网下载的cudatoolkit和conda安装的cudatoolkit有什么区别?是不是只要安装其中一个就可以了?2. 要不要安装cudnn?什么情况下需要安装cudnn?
这两个问题网上很乱,每个人都有不同的理解,我也不知道哪一个是对的。所以想和大佬们请教一下

这个问题我之前做过实验,nvidia官网的cudatoolkit不是直接用于python的,配Python环境不需要安装那个,直接用conda安装就行了。
可以参考这个回答:
如何使用wsl2搭建基于Tensorflow GPU的深度学习环境? - winson的回答 - 知乎

有人遇到过这个问题吗,d2l包安装成功了,但是在具体实例中跑的时候还是显示找不到

谢谢大哥,已按照思路解决M1上d2l的安装。
现在可能所需的Numpy,Pandas版本不一样,按照大哥的方式把每个安装好就可以了pip install d2l。(附一张本人所需的版本)

环境配置须知——注意版本问题:
conda create -n d2l python=3.8
保证这是个纯净的3.8环境,不要提前自己安装各种包。先安装pytorch,再安装d2l里的包
pytorch安装需要到官网里去找,为了防止意外,尽量安装指定的版本,有一个以前的版本页面。
pandas或者其他库如果出现运行错误,导入错误,可能是版本问题,我看了一下,d2l包里的pandas是1.2x版本的,目前pandas已经更新到1.4x了,如果提前安装了1.4x,会导致pandas 1.2x安装失败,这也是前面要保证纯净环境的原因。

Please let me know how to solve this error.
#call the full implemented HyperParameters class saved in d2l
class B(d2l.HyperParameters):
def init(self, a, b, c):
self.save_hyperparameters(ignore=[‘c’])
print(‘self.a =’, self.a, ‘self.b =’, self.b)
print(‘There is no self.c =’, not hasattr(self, ‘c’))
b = B(a=1, b=2, c=3)

AttributeError Traceback (most recent call last)
Input In [28], in <cell line: 2>()
1 #call the full implemented HyperParameters class saved in d2l
----> 2 class B(d2l.HyperParameters):
3 def init(self, a, b, c):
4 self.save_hyperparameters(ignore=[‘c’])
AttributeError: module ‘d2l.tensorflow’ has no attribute ‘HyperParameters’

编译旧pandas会报错,有遇到这个问题吗?本地pandas最新版本这个文件也没有这几行,用的是缓存的旧版本