安装

https://zh-v2.d2l.ai/chapter_installation/index.html

mxnet版本可以安装更高的版本吗?还是只能局限于1.7.0?

Hi @xdkl25, cpu 支持 pip install mxnet==1.7.0.post1; gpu 支持 pip install mxnet-cu101==1.7.0.

1 Like

您好,请问CUDA11.1的mxnet适用版本是哪个

Hi @Dabour, release 都在 https://github.com/apache/incubator-mxnet/releases. 请注意 d2l 使用 mxnet 1.7~

jupyter notebook在linux云服务器安装好了,但是为什么从本地浏览器打不开呢

请大神帮看看这个安装的是否正确呢?我发现一个疑点,跟教程里面不一样的是,我这个jupyter server的网址里面还有token,是不是版本不正确呢?

加上–ip=0.0.0.0后解决,打扰!

1 Like

Ver2 版还支持Windows10 平台吗?没看到相关的安装描述。是不是对于Win用户,只能安装虚拟机之后才能用?
Ver1时,是支持Windows的,http://zh.d2l.ai/chapter_prerequisite/install.html

Hi @zppet, 暂时没有调配Windows,建议直接上云+gpu,方便未来较大model运算。

1 Like

请教一下,这个安装后续需要用到互联网吗?我可以安装在我这边的内网中吗?

我这个是VMcenter里面的虚拟机,可以运行吗?应该是属于没有独立显卡的那种

你好!安装GPU版本的MXnet过程中报错:
Building wheel for numpy (setup.py) … error
请问是什么原因?Python为3.8版本,CUDA退回10.2版本,
用pip install mxnet-cu102==1.7.0 -f https://dist.mxnet.io/python安装无法成功

解决了,应该是因为Python版本太高,从3.8回退至3.6后安装没问题了。

Unreadable Notebook: /Users/leon/study/AI/d2l-zh/tensorflow/index.ipynb NotJSONError(“Notebook does not appear to be JSON: ‘’…”)

按照安装步骤完成了但是出现两个问题。
OS:ubuntu-20.04.1
python3.8 | Miniconda3 Linux 64-bit

1.conda activate d2l后,python中
No module named ‘mxnet’.

2.运行jupyter notebook
jupyter command ‘jupyter-notebook’ not found.

请高手赐教。

以上问题是GPU安装时出现的。
又按照CPU的放发安装了一次,运行jupyter notebook成功。

问题如下:

python3.6 | Miniconda3-4.3.31-Linux-x86_64.sh

1.conda activate d2l后,python中import mxnet
lllegal instruction (core dumped)

请教高手,谢谢。

OS:ubuntu-20.04.1
python3.8 | Miniconda3 Linux 64-bit

第二个问题解决了,运行了
pip install -U d2l

第一个问题发生了变化
1.conda activate d2l后,python中import mxnet
lllegal instruction (core dumped)

请问一下,安装了mxnet过后,import的时候出现module ‘numpy’ has no attribute ‘histogram_bin_edges’,我把mxnet卸载了又安装,还是不行呢

在Win10上安装了基于CPU的环境,可以成功运行。大致步骤:

  1. 先安装miniconda -https://docs.conda.io/en/latest/miniconda.html , 我选的是python3.8
  2. 激活base环境 -cmdline窗口使用命令conda activate base
  3. 到pytorch主页(https://pytorch.org/get-started/locally/ ),获取安装pytorch的命令,我的大概是:conda install pytorch torchvision torchaudio cpuonly -c pytorch

    如果安装中遇到如下错误:
RemoveError: 'requests' is a dependency of conda and cannot be removed from
conda's operating environment.

请使用如下命令更新:conda update --force conda
然后再尝试安装pytorch
4. 然后安装jupyter 和d2l包,在base 环境下,输入pip install jupyter d2l


5. 下载教程的jupyter记事本,就在教材页面右上方工具栏中(https://zh-v2.d2l.ai/index.html

找个合适的目录解压缩

  1. 在base环境下启动jupyter notebook
  2. 一切正常,浏览器自动弹出,即可打开各章节jupyter notebook进行学习和试验了。
    (注:由于是本地CPU版本,很多模型训练很慢,甚至是训练不出来)
1 Like