Installation

@Ali_coder
Recommend my post: Do these before you ask

You can try to google it before you ask. I’m a AMD user, but all Nvidia GPU support cuda in my mind.

If you use mxnet, go to https://mxnet.apache.org/versions/1.6/get_started/

You can use CPU version or CUDA version in your computer.
Or just use a server image


Or just google it:
Can I use MX 250 Graphic Card for basic Deep Learning ?

Then go to the nvidia website:


image
But you can’t find the CUDA download…

So you just search it, then you find mxnet doesn’t support cuda11 yet.


So you search for

You can select the right Platform for your cuda:

http://preview.d2l.ai/d2l-en/master/chapter_appendix-tools-for-deep-learning/aws.html#Installing%20CUDA

After you installed cuda 10.2 , you can install mxnet:
Example:


Give you an exercise:

  1. use google to install pytorch-gpu locally

Ha, I found an cute user. If you are Josiah Yoder, please tell me it’s ok to publish it

Dear All,
Problem with mxnet installation.
I have installed mxnet-cu101==1.7.0 on my ubuntu 18.04, GPU Geforce gtx 1660 Ti. Results show as follows.
Requirement already satisfied: idna<3,>=2.5 in ./anaconda3/envs/d2l/lib/python3.7/site-packages (from requests<3,>=2.20.0->mxnet-cu101==1.7.0) (2.10)
But when I import mxnext it showed errors as follows.

from mxnet import np, npx
Traceback (most recent call last):
File “”, line 1, in
ModuleNotFoundError: No module named ‘mxnet’
Could anyone help me, please?
Thanks in advance.

Hi @Duong_PC, anaconda may be a bit tricky. Could you try with miniconda as https://d2l.ai/chapter_installation/index.html#installing-miniconda?

Thank you very much for the quick reply. May I install both anaconda and miniconda? In case I wanna keep using only anaconda, is there any solution for the tricky? Thanks.

You can use only anaconda.
Only need
conda install what you need
@Duong_PC

Help!

$ pip install mxnet==1.7.0
    ERROR: Could not find a version that satisfies the requirement mxnet==1.7.0 (from versions: 1.6.0, 1.7.0.post1)
    ERROR: No matching distribution found for mxnet==1.7.0

Hi @anish, sorry for the inconvenience. Please follow what the error message suggested:
pip install mxnet==1.7.0.post1

I am getting the error of “NotJSONError(“Notebook does not appear to be JSON: ‘’…”)”

Hi @aaekay, it may cause by git conflict or other jupyter issues, check here for potential solutions.

One easiest solution if you haven’t played with the notebooks yet: you can do a git reset --hard origin/master. While please be aware that will remove all the previous history you made to the notebooks, but update your local content as consistent as the origin/master.

Hi
I just switched to a new computer and surprisingly, cannot install mxnet 1.7.0.post1. Does anyone know why?

$ pip install mxnet==1.7.0.post1
ERROR: Could not find a version that satisfies the requirement mxnet==1.7.0.post1 (from versions: 0.11.0, 0.12.0, 0.12.1, 1.0.0, 1.0.0.post1, 1.0.0.post3, 1.0.0.post4, 1.1.0.post0, 1.2.0, 1.2.1, 1.2.1.post1, 1.3.0, 1.3.1, 1.4.0, 1.4.0.post0, 1.4.1, 1.5.0, 1.6.0)
ERROR: No matching distribution found for mxnet==1.7.0.post1

1 Like

I can’t yet. Issue already:https://github.com/apache/incubator-mxnet/issues/19594
@tdemunck