d2l 0.17.5 request package version too old

Especially the pandas, the latest version was 1.4.2 and I even can’t install pandas 1.2.4

requirements = [

Hi, is there any error when you install d2l==0.17.5 with these pinned dependencies?

in fact I have a lot of installation error before I finally found we must use python3.8 not python3.10.
So I have known that the newset was not always the best.
After I change to Python 3.8 and everything was OK