Language Models and the Dataset

https://d2l.ai/chapter_recurrent-neural-networks/language-models-and-dataset.html

hello,I don’t understand the mean of the Variabel num_subseqs_pre_example which confused me with the general mean of batch_size. In my opinion, mean of the parameter batch_size is the num of subseq per batch, and I think the Variable num_subseqs_per_example should change as the num_batch, what do you think?@astonzhang

Thanks. Given a set of subseqs, the example in num_subseqs_pre_example means a list of subseqs such that batch_size (e.g., 32) of such examples recover the entire set of subseqs. To make it less confusing, I’ve renamed it as num_batches:

Hi to the d2l team.
First of all, thanks for the book.
I found and issue when I try to run the instalation of d2l in colab

      ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
google-colab 1.0.0 requires pandas~=1.1.0; python_version >= "3.0", but you have pandas 1.2.2 which is incompatible.
google-colab 1.0.0 requires requests~=2.23.0, but you have requests 2.25.1 which is incompatible.
datascience 0.10.6 requires folium==0.2.1, but you have folium 0.8.3 which is incompatible.
albumentations 0.1.12 requires imgaug<0.2.7,>=0.2.5, but you have imgaug 0.2.9 which is incompatible.
Successfully installed d2l-0.17.1 matplotlib-3.3.3 numpy-1.18.5 pandas-1.2.2 requests-2.25.1
WARNING: The following packages were previously imported in this runtime:
  [matplotlib,mpl_toolkits,numpy,pandas]
You must restart the runtime in order to use newly installed versions.

Please could you help me to solve the issue?
Thanks,
Andrés.

For a quick fix I have executed the following code before calling the d2l API I used the following code:

!pip install pandas
!pip install requests
!pip install folium
!pip install imgaug

and it worked